- Cloud Spreadsheets - Microsoft Azure Account Creation – Incident details

All systems operational

Cloud Spreadsheets - Microsoft Azure Account Creation

Resolved
Degraded performance
Started almost 6 years agoLasted about 3 hours

Affected

MalgraBooks Services

Updates
  • Resolved
    Resolved

    Issue resolved - all remaining requests will be completed within 24 hours.

  • Monitoring
    Monitoring

    There is currently a delay of approximately 5-7 days for new cloud spreadsheet requests to be processed due to reduced staffing at Microsoft. We apologise for any inconvenience this may cause.