Scheduled for July 13, 2021 at 7:00 AM – 7:00 PM
Completed
July 13, 2021 at 7:00 PMCompleted
July 13, 2021 at 7:00 PMThe scheduled maintenance has been completed.
In progress
July 13, 2021 at 7:01 AMIn progress
July 13, 2021 at 7:01 AMScheduled maintenance is currently in progress. We will provide updates as necessary.
Update
July 13, 2021 at 6:00 AMUpdate
July 13, 2021 at 6:00 AMMaintenance will begin as scheduled in 60 minutes.
Update
July 07, 2021 at 6:43 AMUpdate
July 07, 2021 at 6:43 AMScheduled maintenance has been moved to Tuesday 13 July 2021 due to staff availability at Microsoft.
Planned
July 05, 2021 at 1:22 PMPlanned
July 05, 2021 at 1:22 PMAs part of our MTD plans, our MalgraBooks Client Portal and website may be unavailable for a short period whilst we make updates to our HMRC API Connection.
During this time, client portals may be slower than usual and sections of the MalgraBooks website may be unavailable.
We apologise for any inconvenience caused during this period. Should you need urgent access to your account details, please contact your account manager by email and our team will be pleased to assist.