All fixed. Our system issue has been resolved, thank you for your patience.
Identified
Identified
We've found the issue with BCC emails duplicating. We're on it.
Investigating
Investigating
We're aware that our email service appears to be sending duplicate emails at the moment (better than not receiving any, we guess) - but this is obviously a fault. We're currently looking into the issue.