- Email issues to and from our servers – Incident details

All systems operational

Email issues to and from our servers

Resolved
Operational
Started over 1 year agoLasted 42 minutes

Affected

Third Party Services

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Update
    Update

    We are continuing to investigate this issue.

  • Investigating
    Investigating

    Our third party provider Brevo is currently experiencing a technical fault with their email system which means we currently cannot receive or send emails to/from our CRM systems. If you need urgent assistance please contact us via Live Chat, or if you're a Premium/VAT Member, please use your dedicated telephone contact.