- SSL Failure on MalgraBooks Websites – Incident details

All systems operational

SSL Failure on MalgraBooks Websites

Resolved
Partial outage
Started about 5 years agoLasted about 16 hours

Affected

MalgraBooks Services

Updates
  • Resolved
    Resolved

    This incident has been resolved, and SSL certificates populated accordingly.

  • Identified
    Identified

    The issue has been identified and is caused by a failed overnight backup of the SSL certificate on the server. No data has been lost, and our teams are now refreshing the relevant certificate.

  • Investigating
    Investigating

    We are aware that there is currently a SSL Certificate error on MalgraBooks websites listed below. https://www.malgrabooks.co.uk https://clients.malgrabooks.co.uk This error is caused by an incorrect 'certificate' being allocated against the website, and causes security warnings in browsers as a result. Our technical team are currently investigating this issue.