Scheduled for February 04, 2022 at 8:00 AM – 10:00 AM
Completed
February 04, 2022 at 10:00 AMCompleted
February 04, 2022 at 10:00 AMThe scheduled maintenance has been completed.
In progress
February 04, 2022 at 8:00 AMIn progress
February 04, 2022 at 8:00 AMScheduled maintenance is currently in progress. We will provide updates as necessary.
Update
February 04, 2022 at 7:00 AMUpdate
February 04, 2022 at 7:00 AMMaintenance will begin as scheduled in 60 minutes.
Planned
January 27, 2022 at 11:37 AMPlanned
January 27, 2022 at 11:37 AMDuring January, we paused most major updates to our website to help support consultants during the busy tax return season - as we are clear of the deadline, we'll be updating some key databases and systems as a result to refresh caches and move legacy items from previous tax years.
This is expected to take around 2 hours.