Scheduled for February 28, 2022 at 8:00 AM – 8:30 AM
Completed
February 28, 2022 at 8:30 AMCompleted
February 28, 2022 at 8:30 AMThe scheduled maintenance has been completed.
In progress
February 28, 2022 at 8:00 AMIn progress
February 28, 2022 at 8:00 AMScheduled maintenance is currently in progress. We will provide updates as necessary.
Planned
February 25, 2022 at 5:33 PMPlanned
February 25, 2022 at 5:33 PMWe'll be undergoing some scheduled maintenance on our Client Portal between 8am and 9am whilst we provide updates to our billing system in preparation for our 22/23 package launch.
If you need to access your cloud spreadsheet during this time, please login before 8am and access the document to allow you to continue use during our maintenance period.